WebGate 3.3 ne démarre plus après une mise à jour produit

Après une mise à jour produit vers WebGate 3.3, il est possible que le service ne démarre plus. Cela peut être lié à un test plus sensible de WebGate au niveau des entrées multiples des fichiers clés dans /usr/lib/AntiVir/webgate/.

Dans ce cas, le message d'erreur suivant s'affiche :


Starting: avwebgate.bin
(FAILED)

error: /usr/lib/AntiVir/webgate/avwebgate.bin failed
See log files for details.

Stopping: savapi


Ensuite, un contrôle des entrées suivantes du journal doit être effectué (Pour ce faire, un LogLevel 3 est requis au minimum dans le avwebgate.conf) :

AVWG: ERROR no valid license found, please install a valid full or evaluation license
AVWG: ERROR failed to get savapi info (-30)

Par la suite, veuillez vérifier le nombre de licences dans votre répertoire d'installation :


ls -al /usr/lib/AntiVir/webgate/*.key

S'il existe plusieurs entrées, vous pouvez utiliser l'outil « avlinfo » pour examiner les fichiers clés qui ont expirés entre temps puis les supprimer.
Une autre option consiste à renommer les fichiers clés valides en hbedv.key ou webgate.key.

Avec cette modification, WebGate devrait pouvoir démarrer à nouveau.
Dans le cas contraire, veuillez contacter notre équipe du support technique pour une analyse plus approfondie.

Produits concernés

  • Avira AntiVir WebGate [Linux]
  • Avira WebGate Suite [Linux]
  • Créé le : vendredi 17 août 2012
  • Dernière MAJ: jeudi 28 février 2013
  • Evaluer l’article
Ceci vous a-t-il été utile ?